mirror of
https://github.com/kenshineto/kern.git
synced 2025-04-07 03:11:05 +00:00
39 lines
814 B
Nix
39 lines
814 B
Nix
{
|
|
description = "systems programming x86";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs?ref=nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = {
|
|
nixpkgs,
|
|
flake-utils,
|
|
...
|
|
}: let
|
|
supportedSystems = let
|
|
inherit (flake-utils.lib) system;
|
|
in [
|
|
system.aarch64-linux
|
|
system.x86_64-linux
|
|
];
|
|
in
|
|
flake-utils.lib.eachSystem supportedSystems (system: let
|
|
pkgs = import nixpkgs {inherit system;};
|
|
in {
|
|
devShell =
|
|
pkgs.mkShell
|
|
{
|
|
packages = with pkgs; [
|
|
# (writeShellScriptBin "build" "zig build -Dcpu=baseline")
|
|
gnumake
|
|
gdb
|
|
valgrind
|
|
zig_0_14
|
|
qemu
|
|
];
|
|
};
|
|
|
|
formatter = pkgs.alejandra;
|
|
});
|
|
}
|