dotfiles-guix/home/nix/flake.nix
2024-12-12 19:15:39 -05:00

46 lines
1.1 KiB
Nix

{
description = "Freya Nix Flake";
inputs = {
# nixpkgs
nixpkgs.url = "github:nixos/nixpkgs/55d15ad12a74eb7d4646254e13638ad0c4128776";
# home manager
home-manager.url = "github:nix-community/home-manager/e526fd2b1a40e4ca0b5e07e87b8c960281c67412";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
# nixgl
nixgl.url = "github:nix-community/nixGL/310f8e49a149e4c9ea52f1adf70cdc768ec53f8a";
nixgl.inputs.nixpkgs.follows = "nixpkgs";
};
outputs = {
self,
nixpkgs,
home-manager,
nixgl,
...
} @ inputs: let
inherit (self) outputs;
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
overlays = [
nixgl.overlay
];
in {
homeConfigurations."freya" =
home-manager.lib.homeManagerConfiguration {
inherit pkgs;
extraSpecialArgs = {inherit inputs outputs;};
modules = [
{nixpkgs.overlays = overlays;}
./home.nix
{
_module.args = {
inherit nixgl;
};
}
];
};
};
}