update wm packages and bluez
This commit is contained in:
parent
01f9c0119a
commit
9ed77c16bb
5 changed files with 196 additions and 92 deletions
|
@ -8,11 +8,11 @@
|
|||
#:use-module (gnu packages cmake)
|
||||
#:use-module (gnu packages python))
|
||||
|
||||
(define-public cmake-minimal-3.27.0
|
||||
(define-public cmake-minimal-3.30.0
|
||||
(package
|
||||
(inherit cmake-minimal)
|
||||
(name "cmake-minimal")
|
||||
(version "3.27.0")
|
||||
(version "3.30.0")
|
||||
(source (origin
|
||||
(inherit (package-source cmake-minimal))
|
||||
(method url-fetch)
|
||||
|
@ -21,7 +21,7 @@
|
|||
"/cmake-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1f1w9mb868q38nzy145b6q9mc5waf8yi521cwfkd14xr51mxpvda"))))
|
||||
"0ygmk5wfs00kjx59ackda13049ighgjmyyc0yls4q5aw0pk5nzhm"))))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments cmake-minimal)
|
||||
((#:configure-flags flags ''())
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
(define-module (freya packages freedesktop)
|
||||
#:use-module (guix git-download)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix packages)
|
||||
#:use-module (gnu packages check)
|
||||
#:use-module (gnu packages freedesktop)
|
||||
|
@ -22,3 +23,18 @@
|
|||
(native-inputs
|
||||
(modify-inputs (package-native-inputs libinput)
|
||||
(append python-minimal-wrapper python-pytest)))))
|
||||
|
||||
|
||||
(define-public wayland-1.23.1
|
||||
(package
|
||||
(inherit wayland)
|
||||
(name "wayland")
|
||||
(version "1.23.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://gitlab.freedesktop.org/" name
|
||||
"/" name "/-/releases/" version "/downloads/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1vg5h6d94hglh7724q6wx9dpg4y0afvxksankp1hwbcy76lb4kw6"))))))
|
||||
|
|
|
@ -12,7 +12,7 @@
|
|||
(define-public bluez-new
|
||||
(package
|
||||
(inherit bluez)
|
||||
(version "5.77")
|
||||
(version "5.78")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -21,7 +21,7 @@
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"04h82lfhxh4vd1pyavk1nfrcxc0z5qg5jmsgal9mh22a3pf2y0sx"))))
|
||||
"1qy5fc6z1l3fvcqkvyszzz2xr86yzi2nyphgvsw7bly52lcys3w3"))))
|
||||
(arguments (list
|
||||
#:configure-flags
|
||||
#~(list (string-append "--prefix=" #$output)
|
||||
|
|
|
@ -11,14 +11,6 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
index fa58b63d..51ea6cfa 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -26,7 +26,6 @@ execute_process(COMMAND ./scripts/generateVersion.sh
|
||||
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
|
||||
|
||||
# udis
|
||||
-add_subdirectory("subprojects/udis86")
|
||||
|
||||
if(CMAKE_BUILD_TYPE)
|
||||
string(TOLOWER ${CMAKE_BUILD_TYPE} BUILDTYPE_LOWER)
|
||||
@@ -85,7 +84,7 @@ if(LEGACY_RENDERER)
|
||||
else()
|
||||
set(GLES_VERSION "GLES3")
|
||||
|
|
|
@ -25,6 +25,7 @@
|
|||
#:use-module (gnu packages freedesktop)
|
||||
#:use-module (gnu packages base)
|
||||
#:use-module (gnu packages bash)
|
||||
#:use-module (gnu packages man)
|
||||
#:use-module (gnu packages qt)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix packages)
|
||||
|
@ -48,7 +49,8 @@
|
|||
(define-public swaylock-effects-new
|
||||
(package
|
||||
(inherit swaylock-effects)
|
||||
(version "1.6.11")
|
||||
(name "swaylock-effects-new")
|
||||
(version "1.7.0.0")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -56,15 +58,14 @@
|
|||
(commit (string-append "v" version))))
|
||||
(sha256
|
||||
(base32
|
||||
"0j7dxn66xqlf6iv2arqzz7mxlh7nf85anvpyf30d2frcidarda9h"))))
|
||||
(inputs (modify-inputs (package-inputs swaylock-effects) (delete "linux-pam")))))
|
||||
"0cgpbzdpxj6bbpa8jwql1snghj21mhryyvj6sk46g66lqvwlrqbj"))))))
|
||||
|
||||
|
||||
(define-public waybar-new
|
||||
(package
|
||||
(inherit waybar)
|
||||
(name "waybar-new")
|
||||
(version "0.10.4")
|
||||
(version "0.11.0")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -73,7 +74,7 @@
|
|||
(commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0liiyz6212pmyhpsrb6773qf5b9b4kb76nggizygr9abfidbg5gw"))))
|
||||
(base32 "1bw6d3bf8rm4mgrbcprxxljfxbyabbj2lwabk2z19r8lhfz38myy"))))
|
||||
(arguments
|
||||
(list
|
||||
#:configure-flags #~(list "--wrap-mode=nodownload" "-Dexperimental=true")))))
|
||||
|
@ -93,7 +94,7 @@
|
|||
(build-system meson-build-system)
|
||||
(native-inputs (list gcc-13
|
||||
pkg-config
|
||||
cmake-minimal-3.27.0
|
||||
cmake-minimal-3.30.0
|
||||
libdrm))
|
||||
(home-page "https://github.com/emersion/libliftoff")
|
||||
(synopsis "Lightweight KMS plane library")
|
||||
|
@ -120,7 +121,7 @@
|
|||
(define-public hyprlang
|
||||
(package
|
||||
(name "hyprlang")
|
||||
(version "0.5.2")
|
||||
(version "0.5.3")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -129,9 +130,11 @@
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"17i0372yv0fcwnyki36crz7afw8c5f3j985m083p7rjbh4fn3br6"))))
|
||||
"0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs (list gcc-13))
|
||||
(native-inputs (list gcc-13
|
||||
pkg-config))
|
||||
(inputs (list hyprutils))
|
||||
(home-page "https://hyprland.org/hyprlang/")
|
||||
(synopsis "Official implementation library for hypr config language")
|
||||
(description
|
||||
|
@ -143,7 +146,7 @@ language used in @code{hyprland}.")
|
|||
(define-public hyprcursor
|
||||
(package
|
||||
(name "hyprcursor")
|
||||
(version "0.1.9")
|
||||
(version "0.1.10")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -152,7 +155,7 @@ language used in @code{hyprland}.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0z3ar580n630145nq80qw0p8v0kai6knvhi6nr9z0y1jrb07b0ql"))))
|
||||
"1rdn03ln7pqcwp8h4nmi7nc489q8y25dd3v4paq8ykvwzhvs3a1n"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments (list #:tests? #f))
|
||||
(inputs (list cairo hyprlang librsvg libzip tomlplusplus))
|
||||
|
@ -167,7 +170,7 @@ language used in @code{hyprland}.")
|
|||
(define-public hyprland-protocols
|
||||
(package
|
||||
(name "hyprland-protocols")
|
||||
(version "0.3.0")
|
||||
(version "0.4.0")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -176,7 +179,7 @@ language used in @code{hyprland}.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"01j5hc8qnjzqiiwryfawx1wzrhkn0m794knphyc0vsxwkcmjaj8x"))))
|
||||
"0x86w7z3415qvixfhk9a8v5fnbnxdydzx366qz0mpmfg5h86qyha"))))
|
||||
(build-system meson-build-system)
|
||||
(home-page "https://hyprland.org")
|
||||
(synopsis "Wayland protocol extensions for Hyprland")
|
||||
|
@ -192,7 +195,7 @@ protocols used by Hyprland to bridge the aforementioned gap.")
|
|||
(define-public hyprwayland-scanner
|
||||
(package
|
||||
(name "hyprwayland-scanner")
|
||||
(version "0.4.0")
|
||||
(version "0.4.2")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -201,7 +204,7 @@ protocols used by Hyprland to bridge the aforementioned gap.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1xc2xcxpq61lg964ihk0wbfzqqvibw20iz09g0p33ym51gwlpxr4"))))
|
||||
"0r7ay4zjkfyr0xd73wz99qhnqjq7nma98gm51wm9lmai4igw90qw"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments (list #:tests? #f))
|
||||
(inputs (list pugixml))
|
||||
|
@ -217,7 +220,7 @@ for c++.")
|
|||
(define-public hyprutils
|
||||
(package
|
||||
(name "hyprutils")
|
||||
(version "0.2.1")
|
||||
(version "0.2.3")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -226,7 +229,7 @@ for c++.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0nxx5yb5k9726x95n8gi27xyxyzwb0ma0nj3czpb51sda1k0hz0g"))))
|
||||
"01dh24rf62gb6xm32f7mfv6wx0dxprr1q9y73hvv7xanrjyia2zn"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments (list #:tests? #f))
|
||||
(native-inputs (list gcc-13 pkg-config))
|
||||
|
@ -250,7 +253,7 @@ for c++.")
|
|||
(define-public aquamarine
|
||||
(package
|
||||
(name "aquamarine")
|
||||
(version "0.3.0")
|
||||
(version "0.4.3")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -261,7 +264,7 @@ for c++.")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"114fspibmrwvzdmzv4xdy000vg7mn9r5vas3pr1ndb9xyl15ja1s"))))
|
||||
"0x1zz1ywchs0awkjkvdgskgqnp6pz5lqwmgr8g0zc0i7inhyg1p3"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
(list #:tests? #f))
|
||||
|
@ -285,7 +288,7 @@ for c++.")
|
|||
xcb-util-errors
|
||||
xcb-util-keysyms
|
||||
xcb-util-wm
|
||||
wayland
|
||||
wayland-1.23.1
|
||||
wayland-protocols-1.36))
|
||||
(inputs
|
||||
(list hyprutils))
|
||||
|
@ -314,7 +317,7 @@ for c++.")
|
|||
(define-public hyprland
|
||||
(package
|
||||
(name "hyprland")
|
||||
(version "0.42.0")
|
||||
(version "0.44.1")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -331,12 +334,12 @@ for c++.")
|
|||
"subprojects"))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "1hp2xafvlymikxsi6pr8iik35g46683bg376n9hkjxgh9y6njzqv"))))
|
||||
(base32 "11vw1h9al4jvqprwbrmxvcpxwhvsjj398wbz4flqbnmxa8idvdq1"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
(list #:tests? #f
|
||||
#:build-type "release"
|
||||
#:cmake cmake-minimal-3.27.0
|
||||
#:cmake cmake-minimal-3.30.0
|
||||
#:phases
|
||||
#~(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-path
|
||||
|
@ -376,13 +379,13 @@ for c++.")
|
|||
`("__EGL_VENDOR_LIBRARY_DIRS" prefix ,(list (string-append mesa "/share/glvnd/egl_vendor.d")))))))
|
||||
)))
|
||||
(native-inputs
|
||||
(list gcc-13
|
||||
(list gcc-14
|
||||
jq
|
||||
pkg-config
|
||||
hyprwayland-scanner
|
||||
hwdata-for-hyprland))
|
||||
(inputs
|
||||
(list gcc-13
|
||||
(list gcc-14
|
||||
|
||||
cairo
|
||||
pango
|
||||
|
@ -518,7 +521,7 @@ mo .")
|
|||
(define-public xdg-desktop-portal-hyprland
|
||||
(package
|
||||
(name "xdg-desktop-portal-hyprland")
|
||||
(version "1.3.3")
|
||||
(version "1.3.6")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -527,7 +530,7 @@ mo .")
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"14n4a8b91ili0kp2kjqlw3h57bsxkrjwg5bhlw2h3q93zaxv2b3k"))))
|
||||
"17ba9jkccyp8gv79ds70khgm5wm6x8zs5m9nkilq4n2j7fsa8cfl"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
(list #:tests? #f ;No tests
|
||||
|
@ -544,11 +547,13 @@ mo .")
|
|||
(native-inputs
|
||||
(list gcc-13
|
||||
pkg-config
|
||||
wayland))
|
||||
wayland
|
||||
hyprwayland-scanner))
|
||||
(inputs
|
||||
(list bash-minimal
|
||||
grim
|
||||
hyprland
|
||||
hyprutils
|
||||
hyprland-protocols
|
||||
wayland-protocols-1.36
|
||||
hyprlang
|
||||
|
@ -569,23 +574,21 @@ extra portals specific to Hyprland, mostly for window sharing.")
|
|||
|
||||
|
||||
(define-public hyprland-plugin-hy3
|
||||
(let ((commit "93759c8032995eb566008537389543b3e1b4a65c")
|
||||
(revision "1"))
|
||||
(package
|
||||
(name "hyprland-plugin-hy3")
|
||||
(version (git-version "0.42.0" revision commit))
|
||||
(version "0.44.0")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/outfoxxed/hy3.git")
|
||||
(commit commit)))
|
||||
(commit (string-append "hl" version))))
|
||||
(sha256
|
||||
(base32
|
||||
"0g59zd5724ply38h14r6hafklb8mh0xwb81i0jzzh3xz0r9pmv3s"))))
|
||||
"03gxjkn43j85ff8d0hx9nhv5bfwv7vw7m8kacpmajmfnx43mldg9"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
(list #:tests? #f
|
||||
#:cmake cmake-minimal-3.27.0
|
||||
#:cmake cmake-minimal-3.30.0
|
||||
#:configure-flags #~(list "DCMAKE_BUILD_TYPE=Release")))
|
||||
(native-inputs
|
||||
(list gcc-13
|
||||
|
@ -604,7 +607,7 @@ extra portals specific to Hyprland, mostly for window sharing.")
|
|||
(license license:gpl3)
|
||||
(home-page "https://github.com/outfoxxed/hy3")
|
||||
(synopsis "i3 / sway like layout for hyprland.")
|
||||
(description "Hyprland plugin for an i3 / sway like manual tiling layout"))))
|
||||
(description "Hyprland plugin for an i3 / sway like manual tiling layout")))
|
||||
|
||||
|
||||
(define-syntax hyprland-plugin-impl
|
||||
|
@ -612,7 +615,7 @@ extra portals specific to Hyprland, mostly for window sharing.")
|
|||
((_ plugin)
|
||||
(package
|
||||
(name (string-append "hyprland-plugin-" plugin))
|
||||
(version "0.42.0")
|
||||
(version "0.44.0")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -621,12 +624,12 @@ extra portals specific to Hyprland, mostly for window sharing.")
|
|||
(commit (string-append "v" version))))
|
||||
(sha256
|
||||
(base32
|
||||
"1qzi8c29bam3cj1rngw3gidgphldw7q196iwa9ji5jq071nc1z38"))
|
||||
"0v2zwvrjgc7zg4l8c50934kyq3y5x9f0d34gh3kyh44grfn8w9zx"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
(list #:tests? #f
|
||||
#:cmake cmake-minimal-3.27.0
|
||||
#:cmake cmake-minimal-3.30.0
|
||||
#:phases
|
||||
#~(modify-phases %standard-phases
|
||||
(add-after 'unpack 'chdir
|
||||
|
@ -650,10 +653,34 @@ extra portals specific to Hyprland, mostly for window sharing.")
|
|||
(description (string-append "official " plugin " plugin for hyprland"))))))
|
||||
|
||||
|
||||
(define-public hyprland-plugin-borders-plus-plus
|
||||
(hyprland-plugin-impl "borders-plus-plus"))
|
||||
|
||||
|
||||
(define-public hyprland-plugin-csgo-vulkan-fix
|
||||
(hyprland-plugin-impl "csgo-vulkan-fix"))
|
||||
|
||||
|
||||
(define-public hyprland-plugin-hyprbars
|
||||
(hyprland-plugin-impl "hyprbars"))
|
||||
|
||||
|
||||
(define-public hyprland-plugin-hyprexpo
|
||||
(hyprland-plugin-impl "hyprexpo"))
|
||||
|
||||
|
||||
(define-public hyprland-plugin-hyprtrails
|
||||
(hyprland-plugin-impl "hyprtrails"))
|
||||
|
||||
|
||||
(define-public hyprland-plugin-hyprwinwrap
|
||||
(hyprland-plugin-impl "hyprwinwrap"))
|
||||
|
||||
|
||||
(define-public hyprland-plugins
|
||||
(package
|
||||
(name "hyprland-plugins")
|
||||
(version "0.42.0")
|
||||
(version "0.44.0")
|
||||
(source #f)
|
||||
(build-system trivial-build-system)
|
||||
(arguments '(#:builder (begin (mkdir %output) #t)))
|
||||
|
@ -661,12 +688,81 @@ extra portals specific to Hyprland, mostly for window sharing.")
|
|||
(home-page "https://github.com/hyprwm/hyprland-plugins")
|
||||
(synopsis "A collection of all the official hyprland plugins")
|
||||
(description "A metapackage containing inputs for each official plugin")
|
||||
(propagated-inputs
|
||||
(list (hyprland-plugin-impl "borders-plus-plus")
|
||||
(hyprland-plugin-impl "csgo-vulkan-fix")
|
||||
(hyprland-plugin-impl "hyprbars")
|
||||
(hyprland-plugin-impl "hyprexpo")
|
||||
(hyprland-plugin-impl "hyprtrails")
|
||||
(hyprland-plugin-impl "hyprwinwrap")))))
|
||||
(propagated-inputs (list hyprland-plugin-borders-plus-plus
|
||||
hyprland-plugin-csgo-vulkan-fix
|
||||
hyprland-plugin-hyprbars
|
||||
hyprland-plugin-hyprexpo
|
||||
hyprland-plugin-hyprtrails
|
||||
hyprland-plugin-hyprwinwrap))))
|
||||
|
||||
|
||||
(define-syntax hyprland-contrib-impl
|
||||
(syntax-rules ()
|
||||
((_ contrib)
|
||||
(package
|
||||
(name (string-append "hyprland-conrib-" contrib))
|
||||
(version "0.1")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/hyprwm/contrib.git")
|
||||
(commit (string-append "v" version))))
|
||||
(sha256
|
||||
(base32
|
||||
"0ld0sj7ahf9jf8cqzbqkhj3m2w60027ixic24ih26nwy90b5qjwx"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases (modify-phases %standard-phases
|
||||
(delete 'configure)
|
||||
(delete 'build)
|
||||
(delete 'check)
|
||||
(add-after 'unpack 'chdir
|
||||
(lambda _ (chdir (string-append "../source/" contrib "/"))))
|
||||
(add-after 'chdir 'patch-make
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "Makefile"
|
||||
(("scdoc") (string-append (assoc-ref inputs "scdoc") "/bin/scdoc")))))
|
||||
(replace 'install
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(invoke "make" "install" (string-append "PREFIX=" (assoc-ref outputs "out")))))
|
||||
)))
|
||||
(native-inputs (list scdoc))
|
||||
(license license:expat)
|
||||
(home-page "https://github.com/hyprwm/contrib")
|
||||
(synopsis (string-append "official " contrib " script for hyprland"))
|
||||
(description (string-append "official " contrib " script for hyprland"))))))
|
||||
|
||||
|
||||
(define-public hyprland-contrib-grimblast
|
||||
(hyprland-contrib-impl "grimblast"))
|
||||
|
||||
|
||||
(define-public hyprland-contrib-hyprprop
|
||||
(hyprland-contrib-impl "hyprprop"))
|
||||
|
||||
|
||||
(define-public hyprland-contrib-scratchpad
|
||||
(hyprland-contrib-impl "scratchpad"))
|
||||
|
||||
|
||||
(define-public hyprland-contrib-shellevents
|
||||
(hyprland-contrib-impl "shellevents"))
|
||||
|
||||
|
||||
(define-public hyprland-contrib
|
||||
(package
|
||||
(name "hyprland-contrib")
|
||||
(version "0.1")
|
||||
(source #f)
|
||||
(build-system trivial-build-system)
|
||||
(arguments '(#:builder (begin (mkdir %output) #t)))
|
||||
(license license:bsd-3)
|
||||
(home-page "https://github.com/hyprwm/contrib")
|
||||
(synopsis "A collection of all the official hyprland contrib scripts")
|
||||
(description "A metapackage containing inputs for each official contrib script")
|
||||
(propagated-inputs (list hyprland-contrib-grimblast
|
||||
hyprland-contrib-hyprprop
|
||||
hyprland-contrib-scratchpad
|
||||
hyprland-contrib-shellevents))))
|
||||
|
|
Loading…
Reference in a new issue